<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="Glasstire RSS Feed" href="https://glasstire.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Glasstire Atom Feed" href="https://glasstire.com/feed/atom/" />
<link rel="pingback" href="https://glasstire.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/js/html5.js"></script>
	<![endif]-->

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TV382ZT');</script>

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Letter From the News Editor: One Year On | Glasstire</title>
<link rel="canonical" href="https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Letter From the News Editor: One Year On | Glasstire" />
<meta property="og:description" content="Today marks the one year anniversary of the killing of George Floyd by Derek Chauvin. Chauvin was convicted of second-degree murder, second-degree manslaughter, and third degree murder for kneeling on the&hellip;" />
<meta property="og:url" content="https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/" />
<meta property="og:site_name" content="Glasstire" />
<meta property="article:publisher" content="https://www.facebook.com/Glasstire/" />
<meta property="article:published_time" content="2021-05-25T13:59:05+00:00" />
<meta property="og:image" content="https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg" />
<meta property="og:image:width" content="580" />
<meta property="og:image:height" content="330" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@glasstire" />
<meta name="twitter:site" content="@glasstire" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Christopher Blay">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="2 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://glasstire.com/#organization","name":"Glasstire | Texas Visual Art","url":"https://glasstire.com/","sameAs":["https://www.facebook.com/Glasstire/","https://www.instagram.com/glasstire/","https://www.youtube.com/user/glasstireonline/","https://www.pinterest.com/glasstiretx/","https://twitter.com/glasstire"],"logo":{"@type":"ImageObject","@id":"https://glasstire.com/#logo","inLanguage":"en-US","url":"https://glasstire.com/wp-content/uploads/2018/12/Glasstire-visual-art-in-Texas-Horizontal-Logo.jpg","contentUrl":"https://glasstire.com/wp-content/uploads/2018/12/Glasstire-visual-art-in-Texas-Horizontal-Logo.jpg","width":580,"height":330,"caption":"Glasstire | Texas Visual Art"},"image":{"@id":"https://glasstire.com/#logo"}},{"@type":"WebSite","@id":"https://glasstire.com/#website","url":"https://glasstire.com/","name":"Glasstire","description":"Texas Visual Art News &amp; Reviews","publisher":{"@id":"https://glasstire.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://glasstire.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#primaryimage","inLanguage":"en-US","url":"https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg","contentUrl":"https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg","width":580,"height":330,"caption":"A mural by artists Donkeey Boy and Donkeey Mom, unveiled on June 1, in honor of George Floyd."},{"@type":"WebPage","@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#webpage","url":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/","name":"Letter From the News Editor: One Year On | Glasstire","isPartOf":{"@id":"https://glasstire.com/#website"},"primaryImageOfPage":{"@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#primaryimage"},"datePublished":"2021-05-25T13:59:05+00:00","dateModified":"2021-05-25T13:59:05+00:00","breadcrumb":{"@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/"]}]},{"@type":"BreadcrumbList","@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://glasstire.com/","url":"https://glasstire.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/","url":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/","name":"Letter From the News Editor: One Year On"}}]},{"@type":"Article","@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#article","isPartOf":{"@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#webpage"},"author":{"@id":"https://glasstire.com/#/schema/person/b06f4952cd716319e9b96d363663ce85"},"headline":"Letter From the News Editor: One Year On","datePublished":"2021-05-25T13:59:05+00:00","dateModified":"2021-05-25T13:59:05+00:00","mainEntityOfPage":{"@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#webpage"},"commentCount":0,"publisher":{"@id":"https://glasstire.com/#organization"},"image":{"@id":"https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#primaryimage"},"keywords":"black lives matter,Donkey Boy and Donkey Mom,George Floyd","articleSection":"Feature,Op Ed","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/#respond"]}]},{"@type":"Person","@id":"https://glasstire.com/#/schema/person/b06f4952cd716319e9b96d363663ce85","name":"Christopher Blay"}]}</script>

<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Glasstire &raquo; Feed" href="https://glasstire.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glasstire &raquo; Comments Feed" href="https://glasstire.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glasstire &raquo; Letter From the News Editor: One Year On Comments Feed" href="https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/glasstire.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://glasstire.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='gt-advert-style-css' href='https://glasstire.com/wp-content/plugins/gt-adverts-custom/style/gt-adverts-style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-free-css' href='https://use.fontawesome.com/releases/v5.2.0/css/all.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='penci-soledad-parent-style-css' href='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Raleway%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='penci_style-css' href='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/style.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-gallery-css' href='https://glasstire.com/wp-content/plugins/youtube-channel-gallery/styles.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.magnific-popup-css' href='https://glasstire.com/wp-content/plugins/youtube-channel-gallery/magnific-popup.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://glasstire.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://glasstire.com/wp-includes/js/thickbox/thickbox.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/library/js/framework.js?ver=5.7.2' id='framework-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/library/js/module.dev.js?ver=5.7.2' id='dev-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/library/js/module.glasstire.js?ver=5.7.2' id='glasstire-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/library/js/jquery.carousel.js?ver=5.7.2' id='carousel-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/library/js/jquery.simpleTabs.js?ver=5.7.2' id='simpleTabs-js'></script>
<link rel="https://api.w.org/" href="https://glasstire.com/wp-json/" /><link rel="alternate" type="application/json" href="https://glasstire.com/wp-json/wp/v2/posts/280310" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://glasstire.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://glasstire.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://glasstire.com/?p=280310' />
<link rel="alternate" type="application/json+oembed" href="https://glasstire.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglasstire.com%2F2021%2F05%2F25%2Fletter-from-the-news-editor-one-year-on%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://glasstire.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglasstire.com%2F2021%2F05%2F25%2Fletter-from-the-news-editor-one-year-on%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.gsrtgt { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gsrtgt img { height:auto; }
	.gsrtgt-col { position:relative; float:left; }
	.gsrtgt-col:first-child { margin-left: 0; }
	.gsrtgt-col:last-child { margin-right: 0; }
	.gsrtgt-1 {  margin: 0 auto; }
	.gsrtgt-2 {  margin: 0 auto; }
	.gsrtgt-3 {  margin: 0 auto; }
	.gsrtgt-4 {  margin: 0 auto; }
	.gsrtgt-5 {  margin: 0 auto; }
	.gsrtgt-6 { min-width:0px; max-width:200px; margin: 0 auto; }
	.bsrtgt-6 { margin:0px 0px 0px 0px; }
	.gsrtgt-7 { min-width:0px; max-width:120px; margin: 0 auto; }
	.bsrtgt-7 { margin:0px 0px 0px 0px; }
	.gsrtgt-8 {  margin: 0 auto; }
	.gsrtgt-9 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gsrtgt-col, .gsrtgt-dyn, .gsrtgt-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('glasstire.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<style type="text/css">
				</style>

<style type="text/css">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</style>
<script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/glasstire.com\/wp-content\/themes\/glasstire-new-theme\/soledad\/images\/logo.png"
    },
    "url": "https:\/\/glasstire.com\/",
    "name": "Glasstire",
    "description": "Texas Visual Art News &amp; Reviews"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Glasstire",
    "alternateName": "Texas Visual Art News &amp; Reviews",
    "url": "https:\/\/glasstire.com\/"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Main Sidebar",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Sidebar For Shop Page &amp; Shop Archive",
    "alternateName": "This sidebar for Shop Page & Shop Archive, if this sidebar is empty, will display Main Sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 1",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 2",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 3",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 4",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 5",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 6",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 7",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Custom Sidebar 8",
    "alternateName": "",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "News Asides Sidebar first",
    "alternateName": "newswire first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Author Asides Sidebar first",
    "alternateName": "author first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Blogs Asides Sidebar first",
    "alternateName": "blog first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Videos Asides Sidebar first",
    "alternateName": "video first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Venues Asides Sidebar first",
    "alternateName": "venue first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Venues Asides Sidebar last",
    "alternateName": "venue last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Houston Asides Sidebar first",
    "alternateName": "houston first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Houston Asides Sidebar last",
    "alternateName": "houston last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "DFW Asides Sidebar first",
    "alternateName": "dfw first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "DFW Asides Sidebar last",
    "alternateName": "dfw last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Austin Asides Sidebar first",
    "alternateName": "austin first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Austin Asides Sidebar last",
    "alternateName": "austin last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "San Antonio Asides Sidebar first",
    "alternateName": "san-antonio first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "San Antonio Asides Sidebar last",
    "alternateName": "san-antonio last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "West Texas Asides Sidebar first",
    "alternateName": "west-texas first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "West Texas Asides Sidebar last",
    "alternateName": "west-texas last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "East Texas Asides Sidebar first",
    "alternateName": "east-texas first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "East Texas Asides Sidebar last",
    "alternateName": "east-texas last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "The Valley Asides Sidebar first",
    "alternateName": "the-valley first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "The Valley Asides Sidebar last",
    "alternateName": "the-valley last asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "The Panhandle Asides Sidebar first",
    "alternateName": "the-panhandle first asides sidebar",
    "url": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Letter From the News Editor: One Year On",
    "description": "",
    "datePublished": "2021-05-25",
    "datemodified": "2021-05-25",
    "mainEntityOfPage": "https:\/\/glasstire.com\/2021\/05\/25\/letter-from-the-news-editor-one-year-on\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/glasstire.com\/wp-content\/uploads\/2020\/06\/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg",
        "width": 580,
        "height": 330
    },
    "publisher": {
        "@type": "Organization",
        "name": "Glasstire",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/glasstire.com\/wp-content\/themes\/glasstire-new-theme\/soledad\/images\/logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-ChristopherBlay",
        "name": "Christopher Blay"
    }
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/glasstire.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/glasstire.com\/category\/feature\/",
                "name": "Feature"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/glasstire.com\/category\/feature\/op-ed\/",
                "name": "Op Ed"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "",
                "name": "Letter From the News Editor: One Year On"
            }
        }
    ]
}</script><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://glasstire.com/wp-content/uploads/2018/02/favicon3-50x50.jpg?x31549" sizes="32x32" />
<link rel="icon" href="https://glasstire.com/wp-content/uploads/2018/02/favicon3.jpg?x31549" sizes="192x192" />
<link rel="apple-touch-icon" href="https://glasstire.com/wp-content/uploads/2018/02/favicon3.jpg?x31549" />
<meta name="msapplication-TileImage" content="https://glasstire.com/wp-content/uploads/2018/02/favicon3.jpg" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-280310 single-format-standard">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TV382ZT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<a id="close-sidebar-nav" class="header-3"><i class="fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-3">
<div id="sidebar-nav-logo">
<a href="https://glasstire.com/"><img class="penci-lazy" src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/images/penci-holder.png?x31549" data-src="https://glasstire.com/wp-content/uploads/2018/08/NEW-MASTHEAD.jpg?x31549" alt="Glasstire" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/Glasstire/" aria-label="facebook link" target="_blank"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/glasstire" aria-label="twitter link" target="_blank"><i class="fa fa-twitter"></i></a>
<a href="https://www.instagram.com/glasstire/" aria-label="instagram link" target="_blank"><i class="fa fa-instagram"></i></a>
<a href="https://www.youtube.com/channel/UCs34HqFvE44sbnLmClwXSuQ" aria-label="youtube link" target="_blank"><i class="fa fa-youtube-play"></i></a>
<a href="/subscribe" aria-label="email share"><i class="fa fa-envelope-o"></i></a>
<a href="https://soundcloud.com/glasstire" target="_blank"><i class="fa fa-soundcloud"></i></a>
</div> </div>
<ul id="menu-soledad-primary" class="menu"><li id="menu-item-217324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-217324"><a href="https://glasstire.com">Home</a></li>
<li id="menu-item-217325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217325"><a href="/category/feature/">Articles</a></li>
<li id="menu-item-217327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-217327"><a href="https://glasstire.com/category/newswire/">News</a></li>
<li id="menu-item-217326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217326"><a href="/category/podcast/">Podcasts</a></li>
<li id="menu-item-217348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-217348"><a href="https://glasstire.com/category/feature/top-five/">Top Five</a></li>
<li id="menu-item-273137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-273137"><a href="https://glasstire.com/category/feature/five-minute-tours/">Video Tours</a>
<ul class="sub-menu">
<li id="menu-item-274525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274525"><a href="https://glasstire.com/2020/03/16/seeking-submissions-now-share-short-videos-of-your-texas-art-exhibitions-on-glasstire/">How To Submit</a></li>
</ul>
</li>
<li id="menu-item-217328" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-217328"><a href="/events-landing-page/">Upcoming</a>
<ul class="sub-menu">
<li id="menu-item-217329" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217329"><a href="/event-regions/houston/">Houston</a></li>
<li id="menu-item-217330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217330"><a href="/event-regions/dfw/">DFW</a></li>
<li id="menu-item-217331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217331"><a href="/event-regions/austin/">Austin</a></li>
<li id="menu-item-217332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217332"><a href="/event-regions/san-antonio/">San Antonio</a></li>
<li id="menu-item-217333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217333"><a href="/event-regions/west-tx/">West Texas</a></li>
<li id="menu-item-217334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217334"><a href="/event-regions/east-tx/">East Texas</a></li>
<li id="menu-item-217335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217335"><a href="/event-regions/the-panhandle/">The Panhandle</a></li>
<li id="menu-item-217336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217336"><a href="/event-regions/the-valley/">The Valley</a></li>
<li id="menu-item-247123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-247123"><a href="/event-regions/online/">Online</a></li>
</ul>
</li>
<li id="menu-item-217337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-217337"><a href="/events-landing-page/?event_type=ongoing">On View</a>
<ul class="sub-menu">
<li id="menu-item-217338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217338"><a href="/event-regions/houston/?event_type=ongoing">Houston</a></li>
<li id="menu-item-217339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217339"><a href="/event-regions/dfw/?event_type=ongoing">DFW</a></li>
<li id="menu-item-217340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217340"><a href="/event-regions/austin/?event_type=ongoing">Austin</a></li>
<li id="menu-item-217341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217341"><a href="/event-regions/san-antonio/?event_type=ongoing">San Antonio</a></li>
<li id="menu-item-217342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217342"><a href="/event-regions/west-tx/?event_type=ongoing">West Texas</a></li>
<li id="menu-item-217343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217343"><a href="/event-regions/east-tx/?event_type=ongoing">East Texas</a></li>
<li id="menu-item-217344" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217344"><a href="/event-regions/the-panhandle/?event_type=ongoing">The Panhandle</a></li>
<li id="menu-item-217345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217345"><a href="/event-regions/the-valley/?event_type=ongoing">The Valley</a></li>
<li id="menu-item-247133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-247133"><a href="/event-regions/online/?event_type=ongoing">Online</a></li>
</ul>
</li>
<li id="menu-item-217346" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217346"><a href="/adverts/categories">Classifieds</a></li>
<li id="menu-item-240048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240048"><a href="https://glasstire.com/donate/">Donate</a></li>
<li id="menu-item-245890" class="menu-item-red menu-item menu-item-type-custom menu-item-object-custom menu-item-245890"><a href="https://confirmsubscription.com/h/y/FE0EC3353B9F3A0E">Subscribe</a></li>
</ul></nav>

<div class="wrapper-boxed header-style-header-3">


<header id="header" class="header-header-3 has-bottom-line">
<div class="inner-header">
<div class="container align-left-logo has-banner">
<div id="logo">
<h2>
<a href="https://glasstire.com/"><img src="https://glasstire.com/wp-content/uploads/2018/08/NEW-MASTHEAD.jpg?x31549" alt="Glasstire" /></a>
</h2>
</div>
<div class="header-banner header-style-3">
<div class="gt-adrotate-banner-ad">
<div class="gsrtgt gsrtgt-1"><div class="gsrtgt-single asrtgt-628"><a class="gofollow" data-track="NjI4LDEsMSw2MA==" href="https://blantonmuseum.org/rotation/drawn-from-the-collection-of-jack-shear/"><img src="https://glasstire.com/wp-content/uploads/2021/05/Drawn-728x90-webad-2.3.gif?x31549" /></a></div></div> </div>
</div>
</div>
</div>

<nav id="navigation" class="header-layout-bottom menu-style-1 header-3">
<div class="container">
<div class="button-menu-mobile header-3"><i class="fa fa-bars"></i></div>
<ul id="menu-soledad-primary-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-217324"><a href="https://glasstire.com">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217325"><a href="/category/feature/">Articles</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-217327"><a href="https://glasstire.com/category/newswire/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217326"><a href="/category/podcast/">Podcasts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-217348"><a href="https://glasstire.com/category/feature/top-five/">Top Five</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-273137"><a href="https://glasstire.com/category/feature/five-minute-tours/">Video Tours</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274525"><a href="https://glasstire.com/2020/03/16/seeking-submissions-now-share-short-videos-of-your-texas-art-exhibitions-on-glasstire/">How To Submit</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-217328"><a href="/events-landing-page/">Upcoming</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217329"><a href="/event-regions/houston/">Houston</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217330"><a href="/event-regions/dfw/">DFW</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217331"><a href="/event-regions/austin/">Austin</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217332"><a href="/event-regions/san-antonio/">San Antonio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217333"><a href="/event-regions/west-tx/">West Texas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217334"><a href="/event-regions/east-tx/">East Texas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217335"><a href="/event-regions/the-panhandle/">The Panhandle</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217336"><a href="/event-regions/the-valley/">The Valley</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-247123"><a href="/event-regions/online/">Online</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-217337"><a href="/events-landing-page/?event_type=ongoing">On View</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217338"><a href="/event-regions/houston/?event_type=ongoing">Houston</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217339"><a href="/event-regions/dfw/?event_type=ongoing">DFW</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217340"><a href="/event-regions/austin/?event_type=ongoing">Austin</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217341"><a href="/event-regions/san-antonio/?event_type=ongoing">San Antonio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217342"><a href="/event-regions/west-tx/?event_type=ongoing">West Texas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217343"><a href="/event-regions/east-tx/?event_type=ongoing">East Texas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217344"><a href="/event-regions/the-panhandle/?event_type=ongoing">The Panhandle</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217345"><a href="/event-regions/the-valley/?event_type=ongoing">The Valley</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-247133"><a href="/event-regions/online/?event_type=ongoing">Online</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-217346"><a href="/adverts/categories">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240048"><a href="https://glasstire.com/donate/">Donate</a></li>
<li class="menu-item-red menu-item menu-item-type-custom menu-item-object-custom menu-item-245890"><a href="https://confirmsubscription.com/h/y/FE0EC3353B9F3A0E">Subscribe</a></li>
</ul>
<div id="top-search">
<a class="search-click"><i class="fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://glasstire.com/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="fa fa-close"></i></a>
</div>
</div>
<div class="main-nav-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/Glasstire/" aria-label="facebook link" target="_blank"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/glasstire" aria-label="twitter link" target="_blank"><i class="fa fa-twitter"></i></a>
<a href="https://www.instagram.com/glasstire/" aria-label="instagram link" target="_blank"><i class="fa fa-instagram"></i></a>
<a href="https://www.youtube.com/channel/UCs34HqFvE44sbnLmClwXSuQ" aria-label="youtube link" target="_blank"><i class="fa fa-youtube-play"></i></a>
<a href="/subscribe" aria-label="email share"><i class="fa fa-envelope-o"></i></a>
<a href="https://soundcloud.com/glasstire" target="_blank"><i class="fa fa-soundcloud"></i></a>
</div> </div>
</div>
</nav>
</header>

<div class="container container-single penci_sidebar right-sidebar">
<div id="main" class="penci-main-sticky-sidebar">
<div class="theiaStickySidebar">
<article id="post-280310" class="post-280310 post type-post status-publish format-standard has-post-thumbnail hentry category-feature category-op-ed tag-black-lives-matter tag-donkey-boy-and-donkey-mom tag-george-floyd post_region-austin post_region-dfw post_region-east-texas post_region-houston post_region-san-antonio post_region-panhandle post_region-the-valley post_region-west-texas">
<div class="header-standard header-classic single-header">
<h1 class="post-title single-post-title">Letter From the News Editor: One Year On</h1>
<div class="post-box-meta-single">
<span class="author-post"><span>by <a class="author-url" href="https://glasstire.com/author/christopher-blay/">Christopher Blay</a></span></span>
<span>May 25, 2021</span>
</div>
<div id="single-post-share" class="post-share">
<div class="list-posts-share">
<div class="list-posts-share"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a target="_blank" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Letter%20From%20the%20News%20Editor:%20One%20Year%20On%20-%20https://glasstire.com/2021/05/25/letter-from-the-news-editor-one-year-on/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a target="_blank" href="/cdn-cgi/l/email-protection#ab94d8dec9c1cec8df96e7cedfdfced98e999bedd9c4c68e999bdfc3ce8e999be5cedcd88e999beecfc2dfc4d9918e999be4c5ce8e999bf2cecad98e999be4c58d889b989390e9e4eff296c3dfdfdbd8918484ccc7cad8d8dfc2d9ce85c8c4c684999b999a849b9e84999e84c7cedfdfced986cdd9c4c686dfc3ce86c5cedcd886cecfc2dfc4d986c4c5ce86d2cecad986c4c584"><i class="fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
</div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry">
<div id="attachment_252377" style="width: 590px" class="wp-caption aligncenter"><a href="https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg?x31549"><img aria-describedby="caption-attachment-252377" loading="lazy" class="size-full wp-image-252377" src="https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg?x31549" alt="A-Mural-by-Donkeeboy-Boy-and-Donkeey-Mom-in-Houston's-3rd-Ward-Honoring-George-Floyd" width="580" height="330" srcset="https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd.jpg 580w, https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd-300x171.jpg 300w, https://glasstire.com/wp-content/uploads/2020/06/A-Mural-by-Donkey-Boy-and-Donky-Mom-in-Houstons-3rd-Ward-Honoring-George-Floyd-264x150.jpg 264w" sizes="(max-width: 580px) 100vw, 580px" /></a><p id="caption-attachment-252377" class="wp-caption-text">A mural by artists Donkeey Boy and Donkeey Mom, unveiled on June 1, in honor of George Floyd.</p></div>
<p>Today marks the one year anniversary of the killing of George Floyd by Derek Chauvin. Chauvin was convicted of second-degree murder, second-degree manslaughter, and third degree murder for kneeling on the neck of Floyd, who was only suspected of a crime, for 9 minutes and 29 seconds — killing him.</p>
<p>The protests and uprising that followed in the months afterwards were sustained and global. For our part, Glasstire tried to put the protests in a historical context by <a href="https://glasstire.com/2020/06/19/a-bakers-dozen-14-works-of-art-about-protest-and-police-brutality-1963-2018/" data-emb-href-display="glasstire.com" data-cke-saved-href="https://glasstire.com/2020/06/19/a-bakers-dozen-14-works-of-art-about-protest-and-police-brutality-1963-2018/">sharing the legacy</a> of artists pushing back against police brutality, and by <a href="https://glasstire.com/2020/06/03/dallas-museum-of-art-among-art-institutions-issuing-statements-of-solidarity-amid-national-protests/" data-emb-href-display="glasstire.com" data-cke-saved-href="https://glasstire.com/2020/06/03/dallas-museum-of-art-among-art-institutions-issuing-statements-of-solidarity-amid-national-protests/">covering the news</a> where <a href="https://glasstire.com/2020/06/02/dallas-museums-and-art-damaged-during-ongoing-national-protests/" data-emb-href-display="glasstire.com" data-cke-saved-href="https://glasstire.com/2020/06/02/dallas-museums-and-art-damaged-during-ongoing-national-protests/">protest intersects with art</a>.</p>
<p>With the racial reckoning that seems to be emerging, artists are doing their part, as they always have, being the polished mirror in which society must look, and hopefully find the truth staring back. This is who we are, but we can be better.</p>
<p>I am proud of the work that Glasstire is doing to share the voices of artists, writers, and curators who are constantly pushing us all to be better.</p>
<p>-Christopher Blay</p>
<div class="penci-single-link-pages">
</div>
</div>
</div>
<div class="tags-share-box center-box">
<span class="single-comment-o"><i class="fa fa-comment-o"></i>0 comment</span>
</div>
<div class="subscription-ad-image-holder"><a href="subscribe/"> <img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/subscribe_ad.jpg?x31549" alt="" /></a></div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2018/12/Dallas-Contemporary-art-museum-in-Dallas-Texas-1.jpg?x31549" href="https://glasstire.com/2020/06/09/dallas-contemporary-announces-new-exhibition-everything-hurts/" title="Dallas Contemporary Announces New Exhibition: EVERYTHING HURTS">
</a>
<h3><a href="https://glasstire.com/2020/06/09/dallas-contemporary-announces-new-exhibition-everything-hurts/">Dallas Contemporary Announces New Exhibition: EVERYTHING HURTS</a></h3>
<span class="date">June 9, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/06/A-marble-wall-of-the-Nasher-Museum-with-the-phrase-Black-Lives-Matter-Jume-1-2020.jpg?x31549" href="https://glasstire.com/2020/06/02/dallas-museums-and-art-damaged-during-ongoing-national-protests/" title="Dallas Museums and Art Damaged During Ongoing National Protests">
</a>
<h3><a href="https://glasstire.com/2020/06/02/dallas-museums-and-art-damaged-during-ongoing-national-protests/">Dallas Museums and Art Damaged During Ongoing National...</a></h3>
<span class="date">June 2, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2021/04/Black-Artists-Matter-copy.jpg?x31549" href="https://glasstire.com/2021/04/12/memorializing-matthew-gaines-and-black-artists-at-texas-am-a-reflection-on-art-in-2020/" title="Memorializing Matthew Gaines and Black Artists at Texas A&#038;M: A Reflection On Art In 2020">
</a>
<h3><a href="https://glasstire.com/2021/04/12/memorializing-matthew-gaines-and-black-artists-at-texas-am-a-reflection-on-art-in-2020/">Memorializing Matthew Gaines and Black Artists at Texas...</a></h3>
<span class="date">April 12, 2021</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/07/Attatiana-Jefferson-mural-Fort-Worth.jpg?x31549" href="https://glasstire.com/2020/08/01/a-visit-to-three-new-murals-in-fort-worth/" title="A Visit to Three New Murals in Fort Worth">
</a>
<h3><a href="https://glasstire.com/2020/08/01/a-visit-to-three-new-murals-in-fort-worth/">A Visit to Three New Murals in Fort...</a></h3>
<span class="date">August 1, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/06/A-photograph-by-Ali-Reed-of-Amarillos-Cadillac-Ranch-Trash-cans-painted-with-the-words-Black-Lives-Matter.jpg?x31549" href="https://glasstire.com/2020/06/08/amarillos-cadillac-ranch-painted-with-the-words-black-lives-matter/" title="Amarillo&#8217;s Cadillac Ranch Painted With The Words &#8220;Black Lives Matter&#8221;">
</a>
<h3><a href="https://glasstire.com/2020/06/08/amarillos-cadillac-ranch-painted-with-the-words-black-lives-matter/">Amarillo&#8217;s Cadillac Ranch Painted With The Words &#8220;Black...</a></h3>
<span class="date">June 8, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/06/slowed-and-throwed-June-7-2020.jpg?x31549" href="https://glasstire.com/2020/06/06/slowed-and-throwed-the-mutated-new-lens-of-camhs-hip-hop-show/" title="Slowed and Throwed: The Mutated New Lens of CAMH&#8217;s Hip Hop Show">
</a>
<h3><a href="https://glasstire.com/2020/06/06/slowed-and-throwed-the-mutated-new-lens-of-camhs-hip-hop-show/">Slowed and Throwed: The Mutated New Lens of...</a></h3>
<span class="date">June 6, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/06/800.jpeg?x31549" href="https://glasstire.com/2020/06/05/amid-protests-confederate-monuments-come-down-across-the-u-s/" title="Confederate Monuments Come Down Across the U.S.">
</a>
<h3><a href="https://glasstire.com/2020/06/05/amid-protests-confederate-monuments-come-down-across-the-u-s/">Confederate Monuments Come Down Across the U.S.</a></h3>
<span class="date">June 5, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2020/06/Placard-reading-“community-control-of-police-now”-used-at-Baltimore-protests-in-2015.-Collection-of-the-Smithsonian-National-Museum-of-African-American-History-and-Culture-Gift-of-Sharon-Marie-Black.jpg?x31549" href="https://glasstire.com/2020/06/01/museum-educators-roundtable-board-of-directors-release-solidarity-statement/" title="Museum Educators Roundtable Board of Directors Release Solidarity Statement">
</a>
<h3><a href="https://glasstire.com/2020/06/01/museum-educators-roundtable-board-of-directors-release-solidarity-statement/">Museum Educators Roundtable Board of Directors Release Solidarity...</a></h3>
<span class="date">June 1, 2020</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://glasstire.com/wp-content/uploads/2017/05/knight-thumb.jpg?x31549" href="https://glasstire.com/2017/05/08/autumn-knight-directions-to-prairie-view/" title="Autumn Knight: Directions to Prairie View ">
</a>
<h3><a href="https://glasstire.com/2017/05/08/autumn-knight-directions-to-prairie-view/">Autumn Knight: Directions to Prairie View </a></h3>
<span class="date">May 8, 2017</span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" style="background-image: url(https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/related-posts/default-image.jpg);" href="https://glasstire.com/2015/08/16/relocation-of-jefferson-davis-statue-temporarily-halted/" title="Relocation of Jefferson Davis Statue Temporarily Halted"></a>
<h3><a href="https://glasstire.com/2015/08/16/relocation-of-jefferson-davis-statue-temporarily-halted/">Relocation of Jefferson Davis Statue Temporarily Halted</a></h3>
<span class="date">August 16, 2015</span>
</div>
</div></div>
<div class="post-comments no-comment-yet" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/05/25/letter-from-the-news-editor-one-year-on/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://glasstire.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='280310' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d7416477eb" /></p><input type="hidden" id="ak_js" name="ak_js" value="245" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
</div> 
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-content style-1 pcalign-center penci-sticky-sidebar">
<div class="theiaStickySidebar">
<aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="map"> <h4 id="map-region" class="widget-title penci-border-arrow"><span>SELECT A REGION</span></h4> <ul class="region-items"><li id="map-houston" class="region"><a href="/event-regions/houston/"><span class="screen-reader">HOUSTON</span></a></li><li id="map-dfw" class="region"><a href="/event-regions/dfw/"><span class="screen-reader">DFW</span></a></li><li id="map-austin" class="region"><a href="/event-regions/austin/"><span class="screen-reader">AUSTIN</span></a></li><li id="map-san-antonio" class="region"><a href="/event-regions/san-antonio/"><span class="screen-reader">SAN ANTONIO</span></a></li><li id="map-west-texas" class="region"><a href="/event-regions/west-tx/"><span class="screen-reader">WEST TEXAS</span></a></li><li id="map-panhandle" class="region"><a href="/event-regions/the-panhandle/"><span class="screen-reader">THE PANHANDLE</span></a></li><li id="map-east-texas" class="region"><a href="/event-regions/east-tx/"><span class="screen-reader">EAST TEXAS</span></a></li><li id="map-the-valley" class="region"><a href="/event-regions/the-valley/"><span class="screen-reader">THE VALLEY</span></a></li></ul> </div></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://confirmsubscription.com/h/y/FE0EC3353B9F3A0E" target="new" rel="noopener"><img max-width="100%" alt="subscribe" class="attachment-300x60 aligncenter" style="max-width: 100%;" src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/subscribe-1.jpg?x31549"></a></div></aside><aside id="media_video-2" class="widget widget_media_video"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">&#8216;The Black Women’s Epoch&#8217; by We Here Collective at the Georgetown Art Center. Learn more at: georgetownartcentertx.org</span></h4><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-280310-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=pGfX5rDRLRc&#038;_=1" /><a href="https://www.youtube.com/watch?v=pGfX5rDRLRc">https://www.youtube.com/watch?v=pGfX5rDRLRc</a></video></div></aside><aside id="media_video-3" class="widget widget_media_video"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Building on the Boulevard: Celebrating 20 Years of the Meadows&#8217;s New Home. Learn more at: meadowsmuseumdallas.org</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-280310-2" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=jgISEL3zOPA&#038;ab_channel=MeadowsMuseumDallas&#038;_=2" /><a href="https://www.youtube.com/watch?v=jgISEL3zOPA&#038;ab_channel=MeadowsMuseumDallas">https://www.youtube.com/watch?v=jgISEL3zOPA&#038;ab_channel=MeadowsMuseumDallas</a></video></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget">
<div class="widget-social pc_aligncenter">
<a href="https://www.facebook.com/Glasstire/" target="_blank"><i class="fa fa-facebook" style="font-size: 14px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/glasstire" target="_blank"><i class="fa fa-twitter" style="font-size: 14px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://www.instagram.com/glasstire/" target="_blank"><i class="fa fa-instagram" style="font-size: 14px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.youtube.com/channel/UCs34HqFvE44sbnLmClwXSuQ" target="_blank"><i class="fa fa-youtube-play" style="font-size: 14px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="/subscribe"><i class="fa fa-envelope-o" style="font-size: 14px"></i><span style="font-size: 13px">Email</span></a>
<a href="https://soundcloud.com/glasstire" target="_blank"><i class="fa fa-soundcloud" style="font-size: 14px"></i><span style="font-size: 13px">Soundcloud</span></a>
</div>
</aside><aside id="glasstire_events_widget-2" class="widget glasstire_events_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">We Recommend</span></h4><div class="gt-slideshow-container">
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/05/11/dan-houston-houston-abstraction/" aria-label="Dan Houston: Houston Abstraction">Dan Houston: Houston Abstraction</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Dan Houston: Houston Abstraction" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Dan-Houston-Houston-Abstraction-at-the-Houston-Museum-of-African-American-Culture-in-Houston-May-7-2021-585x320.jpg');" href="https://glasstire.com/events/2021/05/11/dan-houston-houston-abstraction/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/04/23/elizabeth-hill-word-vomit/" aria-label="Elizabeth Hill: word vomit">Elizabeth Hill: word vomit</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Elizabeth Hill: word vomit" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/04/Elizabeth-Hill-word-vomit-at-TERRAIN-Dallas-in-Dallas-May-2-2021-585x320.jpg');" href="https://glasstire.com/events/2021/04/23/elizabeth-hill-word-vomit/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/04/12/laura-sturtz-linear-variations/" aria-label="LAURA STURTZ: LINEAR VARIATIONS">LAURA STURTZ: LINEAR VARIATIONS</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="LAURA STURTZ: LINEAR VARIATIONS" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/04/LAURA-STURTZ-LINEAR-VARIATIONS-at-Link-Pin-Gallery-in-Austin-April-22-2021-585x320.jpg');" href="https://glasstire.com/events/2021/04/12/laura-sturtz-linear-variations/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/04/29/photography-recent-acquisitions/" aria-label="Photography: Recent Acquisitions">Photography: Recent Acquisitions</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Photography: Recent Acquisitions" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/04/Photography-Recent-Acquisitions-at-the-San-Antonio-Museum-of-Art-April-2021-585x320.jpg');" href="https://glasstire.com/events/2021/04/29/photography-recent-acquisitions/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/05/10/2021-annual-juried-utep-student-virtual-art-exhibition/" aria-label="2021 Annual Juried UTEP Student Virtual Art Exhibition">2021 Annual Juried UTEP Student Virtual Art Exhibition</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="2021 Annual Juried UTEP Student Virtual Art Exhibition" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/04/2021-Annual-Juried-UTEP-Student-Virtual-Art-Exhibition-at-the-UTEP-Rubin-Center-in-El-Paso-May-10-2021-585x320.jpg');" href="https://glasstire.com/events/2021/05/10/2021-annual-juried-utep-student-virtual-art-exhibition/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/03/19/ajean-ryan-florid-phobias/" aria-label="Ajean Ryan: Florid Phobias">Ajean Ryan: Florid Phobias</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Ajean Ryan: Florid Phobias" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/03/Ajean-Ryan-Florid-Phobias-at-LHUCA-in-Lubbock-April-2-2021-585x320.jpg');" href="https://glasstire.com/events/2021/03/19/ajean-ryan-florid-phobias/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/05/10/mix-art-show/" aria-label="Mix Art Show">Mix Art Show</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Mix Art Show" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Mix-Art-Show-at-the-Martin-Walker-Law-Firm-in-Tyler-May-8-2021-585x320.jpg');" href="https://glasstire.com/events/2021/05/10/mix-art-show/">
</a>
</div>
</div>
<div class="gt-events-slides fade" style="display: none;">
<div class="gt-events-widget-content">
<h3 class="gt-events-widget-title"><a href="https://glasstire.com/events/2021/05/03/carlos-limas-stillness/" aria-label="Carlos Limas: Stillness">Carlos Limas: Stillness</a></h3>
</div>
<div class="thumbnail event-list">
<a class="gt-events-widget-image-holder" aria-label="Carlos Limas: Stillness" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Carlos-Limas-Stillness-at-IMAS-in-McAllen-May-8-2021-585x320.jpg');" href="https://glasstire.com/events/2021/05/03/carlos-limas-stillness/">
</a>
</div>
</div>
<a class="prev" onclick="plusSlides(-1)">&#10094;</a>
<a class="next" onclick="plusSlides(1)">&#10095;</a>
</div>
<br></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="gt-adrotat-widget">

</div></div></aside><aside id="recent-comments-22" class="widget widget_recent_comments"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Comments</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">John Guess</span> on <a href="https://glasstire.com/2021/05/14/art-league-houston-honors-vicki-meek-as-artist-of-the-year-dr-alvia-wardlaw-receives-lifetime-achievement-award/#comment-1484656">Art League Houston Honors Vicki Meek as Artist of the Year; Dr. Alvia Wardlaw Receives Lifetime Achievement Award</a></li><li class="recentcomments"><span class="comment-author-link">Gail Klein</span> on <a href="https://glasstire.com/2021/02/06/curator-clint-willour-1941-2021/#comment-1484635">Curator Clint Willour, 1941 &#8211; 2021</a></li><li class="recentcomments"><span class="comment-author-link">Annette Carlozzi</span> on <a href="https://glasstire.com/2021/05/14/art-league-houston-honors-vicki-meek-as-artist-of-the-year-dr-alvia-wardlaw-receives-lifetime-achievement-award/#comment-1484416">Art League Houston Honors Vicki Meek as Artist of the Year; Dr. Alvia Wardlaw Receives Lifetime Achievement Award</a></li><li class="recentcomments"><span class="comment-author-link">Rainey Knudson</span> on <a href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/#comment-1484328">Do Art Critics Need to Know How the Sausage is Made?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.tommoody.us' rel='external nofollow ugc' class='url'>Tom Moody</a></span> on <a href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/#comment-1484327">Do Art Critics Need to Know How the Sausage is Made?</a></li><li class="recentcomments"><span class="comment-author-link">Rainey Knudson</span> on <a href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/#comment-1484321">Do Art Critics Need to Know How the Sausage is Made?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.arts.texas.gov' rel='external nofollow ugc' class='url'>Laura Wiegand, TCA</a></span> on <a href="https://glasstire.com/2021/05/14/art-league-houston-honors-vicki-meek-as-artist-of-the-year-dr-alvia-wardlaw-receives-lifetime-achievement-award/#comment-1484316">Art League Houston Honors Vicki Meek as Artist of the Year; Dr. Alvia Wardlaw Receives Lifetime Achievement Award</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.tommoody.us' rel='external nofollow ugc' class='url'>Tom Moody</a></span> on <a href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/#comment-1484258">Do Art Critics Need to Know How the Sausage is Made?</a></li></ul></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="gt-adrotat-widget">
<div class="gsrtgt gsrtgt-6"><div class="gsrtgt-col bsrtgt-6 asrtgt-608"><a class="gofollow" data-track="NjA4LDYsMSw2MA==" href="https://www.redbudgallery.com"><img src="https://glasstire.com/wp-content/uploads/2019/12/luna-logo-inverted-100-x-100.jpg?x31549" /></a></div><div class="gsrtgt-col bsrtgt-6 asrtgt-554"><a class="gofollow" data-track="NTU0LDYsMSw2MA==" href="http://www.deborahcoltongallery.com/"><img src="https://glasstire.com/wp-content/uploads/2016/05/Logo.png?x31549" /></a></div></div><div class="gsrtgt gsrtgt-6"><div class="gsrtgt-col bsrtgt-6 asrtgt-555"><a class="gofollow" data-track="NTU1LDYsMSw2MA==" href="http://www.moodygallery.com"><img src="https://glasstire.com/wp-content/uploads/2020/06/moodygallerylogotile.jpg?x31549" /></a></div><div class="gsrtgt-col bsrtgt-6 asrtgt-609"><a class="gofollow" data-track="NjA5LDYsMSw2MA==" href="https://www.facebook.com/Beeville-Art-Museum-103515313030905/"><img src="https://glasstire.com/wp-content/uploads/2016/07/LogoTile.png?x31549" /></a></div></div>
</div></div></aside><aside id="gt_staff_picks_widget-2" class="widget glasstire_staff_picks_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Staff Picks</span></h4><aside class='widget penci_popular_news_widget'>
<ul class="side-newsfeed display-order-numbers">
<li class='penci-feed'>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Laureates-2021-2022-263x175.jpg');" href="https://glasstire.com/2021/05/18/jennifer-ling-datchuck-annette-lawrence-jesse-lott-and-celia-alvarez-munoz-among-2021-22-texas-state-artists/" title="Jennifer Ling Datchuk, Annette Lawrence, Jesse Lott, and Celia Álvarez Muñoz Among 2021-22 Texas State Artists"></a>
</div>
<div class="side-item-text">
<h4>
<a href="https://glasstire.com/2021/05/18/jennifer-ling-datchuck-annette-lawrence-jesse-lott-and-celia-alvarez-munoz-among-2021-22-texas-state-artists/">Jennifer Ling Datchuk, Annette Lawrence, Jesse Lott, and Celia Álvarez Muñoz Among...</a>
<span class='side-item-meta' style="font-weight:normal;">by
<span style="color: #313131;">Christopher Blay</span>
</span>
</h4>
</div>
</div>
</li>
<li class='penci-feed'>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/BraveBooks-Bjornson-6-copy-263x175.jpg');" href="https://glasstire.com/2021/05/15/collecting-the-border-part-2-a-librarians-library/" title="Collecting the Border, Part 2: A Librarian’s Library"></a>
</div>
<div class="side-item-text">
<h4>
<a href="https://glasstire.com/2021/05/15/collecting-the-border-part-2-a-librarians-library/">Collecting the Border, Part 2: A Librarian’s Library</a>
<span class='side-item-meta' style="font-weight:normal;">by
<span style="color: #313131;">Mary K. Cantrell</span>
</span>
</h4>
</div>
</div>
</li>
<li class='penci-feed'>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/ALH-honorees-Alvia-Wardlaw-and-Vicki-Meek-263x175.jpg');" href="https://glasstire.com/2021/05/14/art-league-houston-honors-vicki-meek-as-artist-of-the-year-dr-alvia-wardlaw-receives-lifetime-achievement-award/" title="Art League Houston Honors Vicki Meek as Artist of the Year; Dr. Alvia Wardlaw Receives Lifetime Achievement Award"></a>
</div>
<div class="side-item-text">
<h4>
<a href="https://glasstire.com/2021/05/14/art-league-houston-honors-vicki-meek-as-artist-of-the-year-dr-alvia-wardlaw-receives-lifetime-achievement-award/">Art League Houston Honors Vicki Meek as Artist of the Year; Dr....</a>
<span class='side-item-meta' style="font-weight:normal;">by
<span style="color: #313131;">Christopher Blay</span>
</span>
</h4>
</div>
</div>
</li>
<li class='penci-feed'>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Texas-Biennial-2021-263x175.jpg');" href="https://glasstire.com/2021/05/10/texas-biennial-2021-artists-announced/" title="Texas Biennial 2021 Artists Announced"></a>
</div>
<div class="side-item-text">
<h4>
<a href="https://glasstire.com/2021/05/10/texas-biennial-2021-artists-announced/">Texas Biennial 2021 Artists Announced</a>
<span class='side-item-meta' style="font-weight:normal;">by
<span style="color: #313131;">Christopher Blay</span>
</span>
</h4>
</div>
</div>
</li>
<li class='penci-feed'>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://glasstire.com/wp-content/uploads/2021/05/Grant-Wood-March-MFAH-1536x1141-1-263x175.jpg');" href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/" title="Do Art Critics Need to Know How the Sausage is Made?"></a>
</div>
<div class="side-item-text">
<h4>
<a href="https://glasstire.com/2021/05/04/do-art-critics-need-to-know-how-the-sausage-is-made/">Do Art Critics Need to Know How the Sausage is Made?</a>
<span class='side-item-meta' style="font-weight:normal;">by
<span style="color: #313131;">Rainey Knudson</span>
</span>
</h4>
</div>
</div>
</li>
</ul>
</aside>
</aside> </div>
</div>

</div>
<div class="clear-footer"></div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy">
<div class="container">
<div class="footer-logo-copyright footer-not-logo footer-not-gotop">
<div class="footer-menu-wrap">
<ul id="menu-soledad-footer" class="footer-menu"><li id="menu-item-217350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217350"><a href="https://glasstire.com/about-us/">About Us</a></li>
<li id="menu-item-274917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274917"><a href="https://glasstire.com/adverts/categories/">Classifieds</a></li>
<li id="menu-item-217355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217355"><a href="https://glasstire.com/donate/">Donate</a></li>
<li id="menu-item-217351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217351"><a href="https://glasstire.com/advertise/">Advertise</a></li>
<li id="menu-item-246730" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246730"><a href="https://confirmsubscription.com/h/y/FE0EC3353B9F3A0E">Subscribe</a></li>
<li id="menu-item-217354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217354"><a href="https://glasstire.com/copyright-notice/">Copyright Notice</a></li>
<li id="menu-item-217353" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217353"><a href="https://glasstire.com/contact/">Contact</a></li>
</ul> <div class="subscribe-link-footer">
<hr>
<h1> <a href="https://confirmsubscription.com/h/y/FE0EC3353B9F3A0E">SUBSCRIBE</a></h1>
</div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='39cb3000df0353001ec9ad009cdd400017793b001536f1006b3b100025601300';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">
      var ajaxurl = "https://glasstire.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
<link rel='stylesheet' id='mediaelement-css' href='https://glasstire.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://glasstire.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='glasstire_events_widget-css' href='https://glasstire.com/wp-content/plugins/gt-events-widget/css/gt_events_widget_style.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/glasstire.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/glasstire.com\/","top_ten_id":"280310","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"709655377"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0' id='tptn_tracker-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/js/libs-script.min.js?ver=5.3' id='penci-libs-js-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/js/main.js?ver=5.3' id='main-scripts-js'></script>
<script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/glasstire.com\/wp-admin\/admin-ajax.php","nonce":"83b268fab3"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad/js/post-like.js?ver=5.3' id='penci_ajax_like_post-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/glasstire.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' id='wp_bannerize_frontend_js-js-extra'>
/* <![CDATA[ */
var wpBannerizeJavascriptLocalization = {"ajaxURL":"https:\/\/glasstire.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-content/plugins/wp-bannerize/js/wpBannerizeFrontend.min.js?ver=3.1.6' id='wp_bannerize_frontend_js-js'></script>
<script async="async" type='text/javascript' src='https://glasstire.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.7.2' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.7.2' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-includes/js/mediaelement/renderers/vimeo.min.js?ver=4.2.16' id='mediaelement-vimeo-js'></script>
<script type='text/javascript' src='https://glasstire.com/wp-content/plugins/gt-events-widget/js/gt-events-widget.js?ver=5.7.2' id='glasstire_events_widget-js'></script>
<div class="funding-wrapper">
<div class="funding-message" align="center">Funding generously provided by:</div>
<div class="funding-list" align="center">
<ul>
<li><a href="http://www.houstonartsalliance.com/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/haa_2020.gif?x31549" alt="Houston Art Alliance Logo"></a></li>
<li><a href="https://arts.gov/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/NEA.jpg?x31549" alt="National Endowement For the Arts Logo"></a></li>
<li><a href="http://www.brownfoundation.org/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/Brown_223w.png?x31549" alt="The Brown Foundation Logo"></a></li>
<li><a href="http://www.houstonendowment.org/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/HE_328w.png?x31549" alt="Houston Endowment Logo"></a></li>
<li><a href="http://www.arts.state.tx.us/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/TCA_194.png?x31549" alt="Texas Commission on the Arts Logo"></a></li>
<li><a href="https://www.neh.gov/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/neh_logo.gif?x31549" alt="National Endowment For the Humanities"></a></li>
<li><a href=" https://www.humanitiestexas.org/" target="blank"><img src="https://glasstire.com/wp-content/themes/glasstire-new-theme/soledad-child-seth/images/footer-images/ht_logo.gif?x31549" alt="Texas Humanities Logo"></a></li>
<ul>
</div>
</div>
</body>
<script type="text/javascript">
// accordion for upcomming events
// jQuery( document ).ready(function() {
//     jQuery(function() {
// 	jQuery('.eventdate').on('click',function() {
// 		jQuery(this).toggleClass("active").next().slideToggle();
// 		});
// 	});
	
//     jQuery(function() {
// 	jQuery('.more-events-toggle').on('click',function() {
// 		jQuery('.more-events').slideDown('slow');
// 		});
// 	});
// });

	
</script>
</html>
